cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to update Amazon Orders

Real-Diva
Occasional Contributor

Hello all, since earlier this morning I have not been able to updated any Amazon orders. At first, when I hit the refresh button, I was receiving this error: An error occurred attempting to update orders: 429, but  since have began to receive this error: An error occurred attempting to update orders: Unauthorized. I have reached out to support, but they are unable to assist me, simply stating that they are aware of this issue and are trying to have it addressed, but are unable to give me any details on how long this would take. Are any of you all having this same issue and if you, how have you gotten it addressed. Please let me know if you all have any pointers or tips and I look forward to hearing from you all!

12 REPLIES 12

john16
Contributor

Yeah same here. I received an email from SS indicating they'd updated the API connecction with Amazon today and that we didn't need to do anything so I thought nothing of it. But now orders are not importing. I can see orders in Amazon's system that are 17 hours old but still haven't imported into SS.

john16
Contributor

Here is the email we received this morning that has coincided with our inability to import Amazon orders.

 

I'm not sure if this is the cause, but it seems likely.

 

Screen Shot 2022-06-22 at 9.48.45 AM.png

john16
Contributor

Just chatted with Support.... they acknowledge it's a problem with ShipStation's update to conform with Amazon's new API. They're very aware of the issue and working on it.

 

Screen-Shot-2022-06-22-at-10.46.14-AM.jpg

Real-Diva
Occasional Contributor

Yes I got the same answer when chatting with support. I will let you know if I get any updates or news. Please do the same!

ShopFlairs
First-timer

Same here. Stopped updating 8 days ago, and they said they are working on it. We should be getting some kind of partial refund for the subscription fee this month.

Real-Diva
Occasional Contributor

Unfortunately I'm feeling we may be looking at the same turn around time as I have a friend that has been having this issue for over a week as well. I will be sure to request some sort of reimbursement if it does end up taking them a while to figure this out.

john16
Contributor

Ok, my issue is ("temporarily") fixed! I received this reply from my chat support guy, and it actually worked.  Note that he indicates that this is a "hotfix to your account" and that it should "temporarily resolve" the issue. So it may be that the fix is specific to my account, and won't work for others, and then will return for me?  Who knows!!!

===================

 

Just following up that my team has deployed a hotfix to your account, which should temporarily resolve this problem.

In order to get this fixed and enabled on your account, you will need to reconfigure your store.
 
Basically, we are renewing the connection with Shipstation to your store to ensure the issue is not related to a broken connection.
 
To do so go to your account settings > selling channels > Store set up > 3 dots next to the intended store > edit marketplace connection (shown here: https://share.getcloudapp.com/04uEGAL1) > follow the prompts on the next screen, after doing so, this has renewed the connection and could have possibly fixed the issue.
 
Once you have done this, your store should work as intended, additionally, I am still going to need to escalate your case so my team and engineers can further investigate and troubleshoot this on our end.

If you have any further issues or questions, feel free to reach out.

peachyapricotde
Occasional Contributor

We're having the same issue with orders not updating. Another issue is that the Amazon marketplace isn't being notified of shipments... So much for us not having to do anything about that API update. 

peachyapricotde
Occasional Contributor

One more issue to add to the pile. Product photos are no longer displayed. We get a grey box instead. It doesn't happen with all orders. It seems to be random.

Deeks88
New Contributor

Amazon and Shipstation are not working at all together anymore. What happened?

I understand V3 isnt being well received, but the lack of urgency is not well received either. 

Just so Management is aware, I even went into the Amazon connect store - to see if I could unstick what (broke) automatically... and noticed people are already leaving bad reviews on Amazon Store Connect. At a (one star) rating, new customers will surely be looking elsewhere. Since your team has cost my and other businesses (LOTS of time lost) how about someone staying late, and looking into whats WRONG.  Maybe bad code? Hack?  ** RollBack is probably the easiest option;  Orders are not coming in thru Amazon... ( its really not that big a deal ) 🤣

CBKnot
First-timer

I have the following error as of an hour ago, An error occurred attempting to update orders: Parameter value '1200.00' is out of range.  It is updating the orders that were in ship station to shipped on Amazon, however it is no longer importing from Amazon to Ship station?  Has this been remedied?  Solution?

Hello there @CBKnot

 

Thanks for posting in the community! 

 

We absolutely want to investigate that error message. 

 

Based on the error message verbiage, I would recommend reaching out to our support team so that we can dig into your account directly and troubleshoot.

 

From Moderator Davis, May the force be with you!