cancel
Showing results for 
Search instead for 
Did you mean: 

Walmart Integration Broken

corey
New Contributor

Anyone else experiencing Walmart integration issues? Our store, which had been working flawlessly for a long time is now suddenly nonfunctional.

 

Shipstation reports an error: 

An error occurred attempting to update orders: There is an error in XML document (678, 3).
 

In discussion with chat/support, Shipstation is 'aware of the issue' and 'working on it', but it's been over a week and no progress.

 

Any ideas on work arounds or other solutions? I've already created new credentials on Walmart as well as creating a new Walmart store in our SS account.

8 REPLIES 8

Moderator-Davis
Moderator
Moderator

Hey there @corey

 

You are exactly right that our support team is actively investigating this Walmart importing error message you are seeing. Im sorry about any frustration you're experiencing, but I assure you that we are checking into this to bring your normal Walmart integration functionality back. 

 

If any other community members have work arounds they have found, I absolutely encourage them to provide that workflow here so that we can all benefit! 

 

Your patience with our support team while we investigate this matter is greatly appreciated! 

From Moderator Davis, May the force be with you!

craig12
New Contributor

Yeah, same issue for me. It's been a nightmare having to manually create orders. Ecomdash is also experiencing this XML issue with Walmart.

Hey there @craig12

 

Thats very good to know! I'm sorry to hear you're also experiencing this issue. I'm confident that with Ecomdash and ShipStation both wanting to resolve this issue with Walmart, that progress will be made soon! Even still, it may be a good idea to bring this knowledge directly to Walmart, if that step hasn't been done already. 

From Moderator Davis, May the force be with you!

@Moderator-Davis - are you able to share any other info beyond the error message we get in SS? Opening a case with Walmart is certainly helpful, but it's easy for them to kick it back to us/SS without a more detailed error response.

From what I would guess it would probably be some issue with special characters in the XML file causing issues. Wednesday/Thursday is going to be the 2 week mark for this issue. At this point I would be fine with seeing some workaround versus a fix from Walmart. There looks to have been a bug fix back in August with this same issue -- https://community.shipstation.com/t5/Blog/ShipStation-Improvements-and-Bug-Fixes-August-08-August-19...

craig12
New Contributor

Looks like Walmart orders are being pulled now. No more XML error. Ecomdash seems to continue to experience an issue.

Howdy everyone! 

 

My team has rolled out a resolution to this XML error we've been seeing with Walmart orders attempting to import! With this in mind, we certainly hope this is an end to the issues that you've run into, but if you continue to see this behavior, please reach out right away as at this time we would consider those instances unrelated. 

 

I hope y'all are having a wonderful day! Happy Shipping! 

From Moderator Davis, May the force be with you!

shippingitems
Contributor

We had a similar issue for a couple of months and were told to contact Walmart directly for the errors. Some orders were cancelled (even though they have been shipped) because the tracking number did not update in Walmart. No issues importing though. It looks like this has been resolved on our end as well recently since we haven't been seeing the error flags lately.