Showing results for 
Search instead for 
Did you mean: 

Canada Post API create label error - "Contract Number is a required field.\r\n"


I'm trying to create a label with the carrier Canada Post via API, but after i enter all the relevant fields for the api call the system returns a 500 error response:


 "Message""An error has occurred.",
    "ExceptionMessage""Contract Number is a required field.\r\n",
This is a weird error because it is not in shipstation docs and i'm not sure what to pass as a parameter even though i have the contract number.
Has anybody had this same issue before?

New Contributor

Just wanted to say that yes, I have had this issue persistently the only workaround was to get OneBalance but now that we have a credit account I would greatly prefer to use the standard Canada Post. Has anyone solved this? 

Hi @anxvtg


Thanks for being a part of our community and for your comment. I see that you were able to reach out to our support team about this and get some answers. 


 Just for community knowledge, this error can occur because of a mismatch of account types. If anyone else is seeing this error message I would first recommend reaching out to our support team, as there are some troubleshooting steps we can assist with when attempting to remove and re-add the account. 


-Erin: Your Friendly Neighborhood ShipStation Community Manager 


Hi Erin,

I have this same error and reached out to your Shipstation support as you've specified, but they told me to contact Canada Post. Can you please provide details on what can be done to resolve this.

I have tried adding and removing our Canada Post account multiple times and nothing works.



Hello, were you able to find a solution for this?

Hello @jadenn  and @DaveHo


Thank you both for reaching out about this. I know you have both reached out to support and have mentioned that you have readded the accounts with no success. I was doing research and we have seen some results from users who have removed the carrier and then have used an incognito browser window to re-add the account and attempt to print a label while still in the incognito mode. 


If you haven't tried this yet, can you please give this a shot for me and let me know if it works for you? 


-Erin: Your Friendly ShipStation Community Manager 


Hello, I am receiving the same error. I have re-added the carrier multiple times and still getting the same error. I have contacted Canada Post and they said everything with the account is fine on their end.

It seems Shipstation is unable to pick up the contract ID number from Canada Post.

Please help.

New Contributor

I was able to connect my Canada Post account after a lot of troubleshooting.
I contacted our sales rep at Canada Post and he put me in touch with someone that handles troubleshooting for tech oriented things like ShipStation. After 10 minutes the account was connected. It turned out we had a Commercial account with Canada Post, and I was using the other option, so that was the main problem. The other issue that the support guy mentioned is that you need to be logged out of Canada Post and only login when you click through from Shipstation. After that, the contract ID number was applied to the account. I would definitely try an incognito window, just to be sure your browser cache is cleared. Other than what i've mentioned here I have no suggestions. The support guy didn't do anything on their end to assist with the connection.

Hope this helps.