cancel
Showing results for 
Search instead for 
Did you mean: 
tony29
New Contributor
Status: Investigating

After using the new ShipStation layout for a long while, I have noticed that it got much slower in all areas. Shipments take longer to load, especially creating new shipments. It also does not appears to be able to handle more than 1 or 2 shipments within the same shipment as it gets slower and slower. Takes way longer to load or search anything.

 

Sometimes when clicking on an order or just hovering over it, a small window of the order details pops up randomly and stays there instead of auto-closing. I have to actually click on the "x" just to close it. That bit is annoying to me.

 

In the legacy layout, I was able to click and drag to select multiple shipments and then drag them to  "+Create a New Batch." But now I have to actually go to "Other Actions" and click "Add to Batch" instead, which takes longer and is less efficient.

 

Another thing that I have noticed was that the shortcut of "ctrl/cmd+A" via "select all" used to apply to only the shipments. But now it does not even do that and actually expands out of that perimeter to highlight the entire window, which is a useless function to me now.

 

I can work around most of these things as they are more of a preference thing, but I cannot get over how slow the interface is. This is a problem especially when I am rushed to create shipments and print orders.

 

If there is anything that I would ask to improve and fix first, it would be to improve the speed and processing of the interface. Using ShipStation as it is now, feels like I'm using Dial-Up internet back in the 90s or something, running on Windows 98.

1 Comment
Status changed to: Investigating
Moderator-Davis
Moderator
Moderator