cancel
Showing results for 
Search instead for 
Did you mean: 
david_dean
Frequent Contributor

This new forum to 'discuss' V3 issues contains 64 "New" ideas, 2 that were "resolved" 4 weeks ago, and none in the investigating or In Progress status.  Am I to understand that means that, in your weekly internal discussions, NONE of these ideas have been discussed or that no work is being done?  Please explain to me, a user who feels completely disappointed and ignored, what to make of this?

6 Comments
_Mia_
Contributor

I've become fairly convinced that they created this forum simply to put criticism out of the way without appearing to ignore it completely. It was an image management move, not a way to actually solve any of the issues. They're all-in on the new version even though it's terrible (and despite over a year of people asking for basic things like restoring orders to be fixed). Which, fine, version changes happen. But they seem to be putting zero effort into the issues which are doing significant damage to our businesses.

david_dean
Frequent Contributor

Agreed.  That's what I find so shocking about the whole thing.  They had the new interface in beta for a long, long time, had collected a ton of bug reports and negative feedback, and then decided to roll it out anyway without addressing the majority of the complaints.  And now that we're stuck with it, and our complaints are mounting, they seem totally uninterested in fixing anything, or even engaging with their users in any constructive, respectful way. 

 

It just makes no sense at all.  What do they do all day over in ShipStation HQ?  Maybe the entire engineering team quit and it's down to just Davis and Erin trying to string us along for as long as possible?  That would explain the situation more than anything else I've heard from ShipStation.

service41
Contributor

I think they are having mass defections.  It certainly seems that way.  As I understand it the company is in turmoil after being bought out a few months ago.   It appears to be corporate infighting between the original crew from Auctane and the stamps.com crowd.   The  magnitude of the slowness issue should be priority number 1.   It's a show stopper for me.   I can survive the other problems but not this for much longer.

ARCreef
Contributor

Bump to hear a mod let us know the status of all the issues please.  Is there anyone working on them???

 

~Long server delays to do even simple tasks ("loading" for 5 mins sometimes to print lables)

~To print another label for an order you have to go inside the order. All carrier information and to add another label are gone from the outside

No longer retains memory on which printer to use, always asks for confirmation, never just prints (yes default printers are all set)

~Can't search by phone number to locate an order or customer

~The shipping price is now super tiny and can barely see it

~It takes multiple extra clicks now to do standard things that used to be super easy and fast to do

~pop ups, random messages, notices, all this clutter crap is always popping up all over the place

~shipped orders says 0 items 0 shipments for all past stuff

~ layout reverts back every time browser is closed (I dont keep cookies, nor should I have to)

~columns take up too much space, cant fit all on the screen that you could in V2

~sometimes it autoprints, sometimes not, sometimes it even prints twice

~it's slowww slowww slowwwww

service41
Contributor

Progress!!!!!!!!!   The status now says "Investigating"  1 issue!!!!    Woohoo.   Wake me up when they fix this pig.

Moderator-Davis
Moderator
Moderator