cancel
Showing results for 
Search instead for 
Did you mean: 

ShipStation Connect on macOS Monterey

gram52
Occasional Contributor

After upgrading macOS to v12.01, all of my printers and scales are still installed and working. But, upon opening ShipStation Connect it will would longer show any printers or scales that a present in macOS. 

 

To trouble shoot,  removed ShipStation Connect and reinstalled it. Now when I launch ShipStation Connect from my application folder, the app opens and then immeditally closes. 

 

Just wondering if anyone else is experiencing this issue?

13 REPLIES 13

markaeaton
Occasional Contributor

Are you running a Mac with an M1 (Apple Silicon) chip? (If so) Do you have Rosetta installed? This is required for Mac apps designed to run only on Intel chips.

If you have an Intel-based Mac, I think a trouble ticket needs to be opened to get this resolved.

 

On a side note, when I asked whether ShipStation Connect has M1 native support so that it can run on new Macs without installing Rosetta, I was directed here to the forums...pretty poor, IMHO, if support doesn't understand the question or doesn't know the answer, shoot it up to the next level of support.

gram52
Occasional Contributor

I use an iMac with a 3 GHz 10-Core Intel Xeon W chip; no need for Rosetta. I did open a trouble ticket. They suggested several things, including reinstalling Shipstation Connect.  After doing so, Connect now opens and then immediately shuts down.

 

I received a phone call from support, and during a remote connection, they were able to confirm the issue. The support tech collected needed information and said they would elevate the case to the next support level. I have not heard back from support at this point.

markaeaton
Occasional Contributor

My issue is slightly different, I made the jump to an M1-based Mac (super fast and the battery lasts a couple of days), trying to avoid running Rosetta, which I have so far. Luckily I don't ship a ton of products so I'll download/print rather than having the simplicity/benefits for ShipStation Connect, for now.

 

I was a little disappointed that support suggested I raise this issue here, rather than opening a trouble ticket.

Jw123
New Contributor

Anyone figure this out yet? I have to keep downloading labels to print them it’s a pita snd time consuming. 

gram52
Occasional Contributor

I checked the trouble ticket I submitted, and it has been elevated to the next level of support. I've heard nothing on it yet.

Hello there, everyone! 

 

I just wanted to drop in and say that the product team is aware of this issue and we are actively working on a resolution! When that ShipStation Connect update is finalized, we will certainly make note of it here in the community. 

 

 

From Moderator Davis, May the force be with you!

Would be great if someone could send us a link to the new software that will allow us to use ship station again since I'm paying over $30 a month for a program that won't work properly at the moment.

sales331
First-timer

Same issue with my Intel Mac just updated to Monterey

gram52
Occasional Contributor

Support just contacted me with an update, V2.29.0. I installed it and it is working on my Mac.

Jw123
New Contributor

Unless they sent you a version via email, the one on their website still doesn't work for me unfortunately.

markaeaton
Occasional Contributor

The currently available (public) version is 2.4.1, and it's an Intel app still. In case anyone gets their hopes up.

Same issue for me, the other poster must have received a special download link via email.  The one on their website still doesn't work for me.

Moderator-Davis
Moderator
Moderator

Hello all! 

 

I've pleased to announce that a brand new ShipStation Connect version is on the way soon, and we have tested and confirmed that it will have regularly working functionality with iOS Monterey! 

 

When the new version becomes available, you will absolutely see updates from us 🙂 

 

Happy Friday! 

From Moderator Davis, May the force be with you!