Showing results for 
Search instead for 
Did you mean: 
Status: Resolved

Are Advanced Hotkeys working in the new layout for anyone? This post from March of 2021 says they're added, but I've been unable to get them working and support seems clueless. There's a hotkey menu in the new layout which implies they're working. The help center article on "Other Barcode Uses" has a notice saying that the scan action report is only available in the legacy layout, but doesn't clearly say the barcode actions (which are just hotkeys mapped to a barcode) don't work in the new layout.


The basic hotkeys, including Shipping Presets work fine, but the advanced hotkeys (and I'm specifically looking for "Read weight form scale" (w), "Get Rate" (r), and "Create label" (s)) all appear broken.


One more piece of info in case anyone else is running into this same issue. There's a post over in the ShipStation University Hub where a moderator acknowledges that barcode actions (and by implication advanced hotkeys) aren't working and states that a fix was planned to be rolled out by the end of March 2022. Those posts were made in February 2022. So we're late, but hopefully a fix is coming soon.

Hey there @d-a-v-i-s


We have rolled out that scan functionality. If the scan functionality specifically isn't operating as intended for you, please reach out to our support department so that we can fully troubleshoot that issue, and if needed, have the feature further reviewed. 


The advanced hotkeys however, are a separate feature that is being worked on currently. I wish i had more information to share in this moment, but we do not yet have an ETA for that update. Certainly as soon as I have any new information, I will update the thread accordingly so that we are all on the same page 🙂 




Please fix the kotkeys! Even the arrows in the order window don't work from keyboard. Not to mention s - for shipping w - weighing etc.. Help!!


Hi @Moderator-Davis. I just wanted to add some clarification to this post in case anyone else finds it. Please correct me if I get anything wrong.


Most of the Scan functionality in ShipStation is just a barcode that maps to a Basic or Advanced Hotkey. The hotkey support in ShipStation allows you to build a streamlined pick and pack process for your warehouse. For example, here's what our shipping team does in ShipStation once an order is packed.


  • Scan pick ticket barcode to bring up Order in ShipStation. (This is working in the new layout.)
  • Scan the "Read weight from scale" barcode to update the order weight in ShipStation. (This is broken in the new layout.)
  • Scan the appropriate Custom Shipping Preset for the package being used. (This is working in the new layout.)
  • Scan the "Get rate" barcode to get the shipping cost for the order. (This is broken in the new layout.)
  • Scan the "Create label (Ship Order)" barcode to generate the shipping label. (This is broken in the new layout.)

So when everything is working, our shipping team can take a packed order and get a label without ever having to touch the keyboard. But aside from the pick ticket barcode in those steps above, all of the scan actions are just mapping a barcode to a HotKey. And 3 of those 4 HotKeys are "Advanced Hotkeys" that don't work in the new layout.


I'd really like to add the Scan to Verify feature to our packing workflow, but Scan to Verify only works on the new layout and the new layout and since the new layout would break our current scan to ship process, I'm stuck.


ShipStation says scan functionality works in the new version, but it's misleading. Anyone trying to setup a streamlined scanning-based pack and ship workflow, is in for disappointment as key steps in the process don't work via scanning.


ShipStation Hotkeys



Hey @d-a-v-i-s


Thank you for providing this feedback.


You are correct that there are some aspects of Hotkeys that we are still working on! With that in mind, we have not received reports of the Advanced HotKeys specifically not working. We definitely want to investigate that to the root of the behavior you are experiencing.


Please be on the look out for a direct message from me soon! 


If anyone else is experiencing this behavior specifically with the Advanced Hotkeys, please reach out to our Support team so that we can document that and investigate accordingly. 




Not be salty about this, but ShipStation support has received at least 2 reports of Advanced Hotkeys not working on the new layout. I opened a ticket in December 2021 (six months ago) where the support rep was unable to replicate my issue, I submitted video of it not working and the ticket was escalated. In April of 2022 a support rep told me they were able to replicate the issue and the ticket was escalated. I've heard no follow-up on either ticket since.


I'm assuming this feature is actually working for some people on the new layout, which would lead me to believe it's something specific to my setup. I have tried the basic resolution steps that support has suggested (clearing cache, incognito window), as well as trying different browsers and computer combinations with no results. This is Windows 10 on some basic hp laptops and workstations. Nothing unique on the hardware or OS side. I'm happy to try more, but need some sort of response from support.

Thank you for providing this insight to your previous tickets! 


We will consolidate this information into the investigation into this behavior right away. As soon as I have any updates I will update everyone here 🙂 



So in order for the arrows on the keyboard to work in the order window so I can navigate to the next order I have to click on the order window again as if I clicked away when I clicked on Create$Print Label in the same window (which was accomplished by pressing S in the old version). With this additional click it defies the whole arrow function as a hotkey................. I'm pretty annoyed by this as this adds unnecessary clicks and additional steps.

Also I don't like I cannot view the order that I just shipped by pressing the back arrow. Sometimes I need to verify and make sure I didn't make a mistake and I need to click away from the order window and go find the order I'm looking for. Another way to waste my time. Ugh


We completely agree... the new layout is not intuitive and has a poorer UIX. On top of the issues of hotkeys not working in the order screen, at the grid layout with sidebar, the hotkeys initially work but after a label is created + printed (S), the grid loses focus and we're unable to navigate with hotkeys, even the standard ones such as down arrow to move to the next order in the grid... we're having to reach for the mouse each time now and has slowed down our workflow considerably.


There's other issues with the new layout but for just keeping it to hotkeys on this post... are we still able to switch back to V2 Legacy? Only reason we migrated was due to the email announcing that we were all going to be forced into the new layout on May 5.


We just switched to the new layout due to a forced migration email we received and we're having issues with the hotkeys as well. We don't use scanning in our shipping workflow, but given that hotkeys aren't working in the following cases, it might be the cause of your issue as well:


When we're viewing an order in "Orders", advanced "Shipping Orders" hotkeys are not functioning, however, "General" hotkeys are initially... but once a label is created + printed, focus is lost and not even "General" hotkeys functioning, requiring to click the "Forward" arrow to move on to the next order... which has become tedious.


We actually normally just work off the grid layout with the sidebar but tried using the order screen to see if we can get back our quicker workflow. The grid layout has similar hotkey issues. Although "Advanced Hotkeys" initially do work, once a label is Created + Printed, it loses focus and "General" hotkeys no longer work (ie. down arrow to move to the next order in the grid).


Overall, our productivity has slowed down significantly and are now even considering transitioning to other services if the hotkey issue can't be resolved soon or if we're unable to switch back to legacy until they are...