cancel
Showing results for 
Search instead for 
Did you mean: 

Missing or invalid shipper name

BoonesOvertock
First-timer

I have a UPS account with negotiated rates that I seem to have successfully added to my SHIPSTATION account.  The negotiated rates do show and everything looks fine until I select the option to print the label, I get the message that says:  "Missing or invalid shipper name"

 

I have not been able to get SHIPSTATION to respond to even one single e-mail or phone call.  The customer service for ShipStation has been deplorable.  Please advise.  I need help.  

 

Matt

 

 

4 REPLIES 4

Moderator-Davis
Moderator
Moderator

Hey there @BoonesOvertock

 

Thanks for joining us here in the community! 

 

When we see "Missing or invalid shipper name" when making a label via UPS, it means that we need to go to the Ship From Location in ShipStation and make sure that all fields have been filled in, including full name and company name. Without those filled in, we can continue to see this error message populate. 

 

Just as a heads up, you will want to ensure those fields have been included for the returns side of that Ship From Locations window as well 🙂 

 

I hope this helps! 

From Moderator Davis, May the force be with you!

Thank you for the response.  I do not understand the problem.  Those ship-from-location and return address fields are already filled out and used everyday shipping USPS.  The only difference is my UPS account is under a different name than my ShipStation profile (one is Boone's Overstock and the other is Brutal Planet).  The address is already in there for both fields, so why won't it work?  I feel like I need more than the force to get this working....

 

Matt  

Thanks for getting back to me, though, I am sorry you're still seeing this error. 

 

Be on the lookout for a DM from me for some account specific information so maybe we can get to the root of this 🙂 

From Moderator Davis, May the force be with you!

wjb21ndtown
First-timer

My experience with Shipstation has been equally horrible.

 

I have also received the "Missing or Invalid shipper name" warning.  I successfully resolved the issue for my account, by adding my company name to the "optional" company name field.   I recommend putting something in that field and trying again.

Good luck, the service seems awful.