cancel
Showing results for 
Search instead for 
Did you mean: 
tomb
Occasional Contributor
Status: Investigating

So we're 1 month in on the new format. I was hoping to get use to it but I'm discovering it's not really a matter to get use to. I'm going to try and be constructive with my comments as I know ShipStation will not let us go back to the old version. I use BigCommerce (BC) as my business platform and ShipStation (SS) for shipping. Things that have changed:

(1) If I make, say a change of address in BC, it use to carry over to SS and would automatically make the change. The new version won't make the change. I have to do it manually.

(2) With the new version on some orders I have to manually plug in customs info in SS. Before I never had to do this.

(3) I still plug in on every order whether the order is Ground or International. I also plug in my box size. No big deal. Now when I plug in the info I find that about 25% of the orders never take the info I plug in. So when I go to print a label I have to fill it in again. Very time consuming.

(4) The new version is slow. This is not a matter of opinion, it's slow. Also, it's way too busy. The whole format on the individual order page is too convoluted. In the old version I could size my screen and include all of my products and the screen was big enough to read comfortably. Now I have to size my screen down really small to see everything or leave it bigger but then have to use the scroll bar. Slows things down. Along with this is just the lag time with everything.

I hope someone in SS management reads this. I tried to find the page "Erin" was supposed to have set up for constructive feedback but I can't find it. If we're stuck with this SS has got to do some tweaking. I honestly do not see any improvements at this time. Changes such as these are supposed to streamline the process. This new version has done the opposite.

5 Comments
nick
Occasional Contributor

I feel like the programmers doing the layout have 30" 4K monitors, so it all looks good to them. But in the real world people like me have 17" & 19" monitors 1024x768 resolution.

If this is even being monitored, the layout does not scale down good! Too much padding around everything! Too much scrolling!

tomb
Occasional Contributor

Makes sense Nick. I wonder if any of ShipStation's programmers read these comments?

_Mia_
Contributor

It seems as though they're putting all their resources into migrating people over to the new version before fixing the fundamental issues with it. Many of these things should be relatively easy fixes, it seems as though they're simply choosing not to fix it. Things like printing defaults not saving or no default filters on the search or the font on the rate value being too small, etc.

 

Also, remember when @Manager-Erin said they'd be far more transparent and communicative about what they're working on and trying to improve a month ago?

We have heard your calls for more transparency and communication. Going forward, we plan to be as communicative and transparent as possible with you about this new layout and the work being done to address your blockers.

 

...A task force will be reviewing all posts and comments from this section on a weekly basis to prioritize fixes where possible and address provided feedback internally.  We will also publish content to show you what is currently happening, what might be blocked, and what is planned where possible.

Yep, it was a lie. Which is pretty much what I've come to expect from shipstation at this point. It's been a month and there's been basically zero communication, just as before. Just more sterile release notes that don't explain anything and don't even come close to addressing the most pressing productivity issues such as the painful slowness of the interface caused (in part) by reloading the rate constantly after nearly every keypress.

tomb
Occasional Contributor

The latest thing I've found is this: If I get a large order in I could split into 2 separate boxes and create 2 labels. I could change the box size and weight and create another label. SS would prompt saying "this order has shipped do you want to create another label".

Now it will only let me do one. If I do the second I have to go to UPS, USPS or FedEx and do it manually.

I cannot begin to explain how sick I am of this. I've been through USPS and UPS changes in their systems and after a brief learning curve it became easy. This is a different animal all together. After 5 weeks you would think it would get smoother. It's horrible and a damn robbery of the money we pay. I'm actively searching for a new shipper that I can integrate into my system. 

Dammit SS put us back on the old version!!!!!  This V3 crap does not have 1 thing that has been an improvement. NOT ONE!

Status changed to: Investigating
Moderator-Davis
Moderator
Moderator