cancel
Showing results for 
Search instead for 
Did you mean: 

Software Update

JoshSimone
First-timer

We just updated to the new version of shipstation this month. My staff was complaining and i though it was just because they do not like change. With some of the staff on vacation i was able to use to the new version my self. The new version of ship station is terrible. I have been using ship station for many years and i have had no problems up to now. It had me wondering if you guys even tested it out before releasing it. I'm left scratching my head on how bad this is.

 

1)The page as a whole is very slow to respond. When you try to make a postage selection the boxes do not respond well. I often have to select a postage provider or box type two or three times. Terrible, terrible, terrible

2) Check boxes next to orders are very slow to respond. They do not work correctly and its not my internet connection. I checked the box next to the order and sometimes i have to do it twice. If i do check the box successfully it refreshes the page. Terrible, terrible, terrible 

3) Batch labels get delayed and often i have to do the process twice. Loading errors are very common and it disrupts work flow 

4) Customs info is not added in automatically like the last version. Like international orders aren't a pain as it is- now i have to manually add customs info which disrupts workflow. 

5)The pictures for half of my products are importing into shipstation automatically like before. I large majority of my items have no picture. 

 

I though new software should make things easier for the seller not harder. 

In the ecommerce world inches make champions- If you loose a little bit of ground you are out of business

This new software is terrible, terrible, terrible. 

For the first time after many years i am thinking of finding a new shipping software

Someone at your company should be held accountant able for how bad this software is 

 

 

3 REPLIES 3

Moderator-Davis
Moderator
Moderator

Hello there @JoshSimone

 

Thanks for bringing us this feedback. We definitely want to hear what is not working for you about the new layout. 

 

In order to get that sort of interface feedback (your #s 1 and 2) with the right folks, I would encourage you to find the GIVE FEEDBACK button in blue lettering at the top of the page. Leaving a comment there for feedback will be beneficial in going along with your feedback here that I am providing to my product team. 

 

Reviewing your post, looking at numbers 4 and 5 specifically, these sound like they could potentially be direct and account specific issues you are running into. Due to this, I highly recommend following up with our support team to get to the bottom of these behaviors ASAP. I will be direct messaging you about some of the wheels that I have already put in motion on your behalf. 

 

I hope you're having a wonderful day! 🙂 

From Moderator Davis, May the force be with you!

aggie
New Contributor

We're also experiencing 1 and 2, very slow. I'm not sure how long it's been going on, perhaps several weeks. Support cleared our backend cache on Aug 9, and that seemed to help for a while. It's not slow all of the time, but most of the time. 

We must get this resolved to continue with shipstation. How can I help? Shall I post another thread here? I don't see the blue Give Feedback button you mentioned.

aggie
New Contributor

Hold on my earlier reply. Support may have found a fix. I need to do more testing.