Showing results for 
Search instead for 
Did you mean: 

product import errors - 3 YEARS UNRESOLVED


I have yet to get help for this error.  

After 6 years, creating a csv to match the format is not difficult. Why won't the imports work?

Chat support escalates the issue and I've been bombarding this community, but to no avail.. 

What is wrong with my file 





Occasional Contributor

Have you tried it by removing the "?" from the product names?  I would also do a "=CLEAN" on column B after removing the "?" and try again.

Thanks @Shane_Kinney 


Only thing I can think of is SS does not like special characters in product names. The "#" in some rows might be causing your problems given that your issues start at row 5, which has the pound sign. 

Hey there @teamLA


I see that you are still working on fixing up this product import CSV. 


I think that @Shane_Kinney and @jchin1234, are both right on the money! If there are still any sort of "special characters" in the CSV (like a ? or #) then we can see an error when attempting to import. Reviewing your CSV to remove any special characters like this, is the best troubleshooting step to take next! 


With that in mind, if you do so, and then are still getting that error message, please reach out back out to me or on this thread. 


Thanks so much to both @Shane_Kinney and @jchin1234 for helping their fellow ShipStationer out! Y'all are awesome! 


Happy shipping! 🙂 

From Moderator Davis, May the force be with you!

Yes, of course I've tried simple formatting.  @Moderator-Davis 

Thank you

New Contributor

Make sure the csv file is closed before importing it?

New Contributor

Open your csv file in a true plain-text editor such as Notepad++ or UltraEdit. Do not trust Excel or Google Sheets, and do not open it in WordPad or MS Word. Once open in the plain text editor make sure there are no invisible characters or incorrect formatting. As a test maybe delete all of the records except a small subset (10 or 20 records) and work only this this file, making small changes until you narrow it down.


Excel and Google Sheets are NOT your friend when it comes to csv and other types of delimited text files. I suspect the issue is inherent in your files, but when open in Excel or Google Sheets you can't see it. These apps try to be helpful and will do things like hide invisible characters (like line breaks or non-ASCII characters), or (incorrectly) make assumptions and reformat number fields, or round values, or remove leading zeros. 


New Contributor

I noticed the very first row in your data file had values. Then the second line has your field headers, and then all of the fields appear below that. Delete the first row. (Looks like it contains formulas). Even if your print range starts at row 2, that doesn't mean your csv file will necessarily also start at row 2. As I mentioned earlier, make sure you install a plain-text editor such as Notepad++ (It's a free program) and open your csv file in there, and use that to track down the issue.

Hey there @rocinante


Thanks so much for this information and guidance for csv importing! Your participation and sharing in the community is greatly appreciated! 🙂 

From Moderator Davis, May the force be with you!