Showing results for 
Search instead for 
Did you mean: 

"Invalid Product" when scanning order number?


This just started recently, and according to reports from the warehouse crew it seems to only be happening on orders after this past weekend.


They normally login on the iPads, go to the Scan+Verify screen, and scan the order number in, then verify the items. They would then scan the next order number and repeat. However, with orders after this past weekend, they say that when scanning the order number it gives them "Invalid Product", and they have to manually tap on the order number input field and scan it, sometimes having to do this twice.


They did note the iPads had a software update, so I am unsure if it is connected or not, but looking for guidance and other experiences.


I tried this on my iPad here, but I'm running beta iPadOS 15, and tried Scan+Verify on already shipped orders (so as not to mess up any shipments they are working on) and outside of having to tap on the order number field, everything seemed to work fine. I didn't get an invalid product message at all.


Anyone else?



To produce the problem, running on iPad 8G with iPadOS 14.7.1:


* Go to Scan + Verify

* Scan the first order

* Verify all the items on the order

* Press Mark As Verified

* See the verification that the order is validated

* The focus is on the top bar to find shipment

* Scan the next order

* Receive "Incorrect Product" message

* Dismiss error, tap on order box, and scan next order

* Verify items on order


This did not happen on older orders. Also, if you don't mark the order as verified, you can tap in the top bar to switch between orders by scanning them at will. Once you verify all the items and mark it as verified it tells you the order is verified and highlights the top search bar, but scanning a new order gives the Invalid Product message. Dismissing that and re-selecting the search box allows you to scan the next order. The process repeats.


This is a huge annoyance and workflow interruption.


Just FYI for anyone reading, I filed a ticket.

New Contributor

Hello, has anyone gotten back to you?


This issue was resolved in a recent update to the platform.

Maybe you can guide me on an issue I am having. When I go to Insights > Reports > Barcode Scan Action Report > Scan Action Type > Custom Shipping Presets > Export to PDF and the pdf is blank.


I tried two different browsers, cleared cache, added and removed presets and tried again, several times, and the pdf is still blank.


Any thoughts on this?