cancel
Showing results for 
Search instead for 
Did you mean: 

Bug - dimensions not populated for UPS Package Types

RobC
Contributor

We are using UPS Large, UPS Medium and UPS Express Pak packaging.  When you select one of these, the dimensions do not update, so the rate is wrong unless your package weight happens to be greater than the dimensional weight would have been had the dimensions been entered.

UPS charges adjustment fees when you ship with the wrong weight/dimensional weight.

This seems like such a glaringly obvious bug.  What am I missing here?

 

4 REPLIES 4

JakeM
Contributor

Dimension handling in general seems wonky in some cases. For instance, if you Bulk Update package type, and the orders you are applying this to are all the same Carrier and Service, you can therefore select a package type which does not include dimensions as part of the dialogue to apply the bulk update. Intuitively, this would apply the package type and leave dimensions unchanged; instead, it overrides dimensions on all such orders to be 0x0x0. I think for whatever reason the package type and dimensions are handled completely separately, and in cases where they would conflict it is not uniform which (package type or dimensions) takes precedence. 

You probably already have a workaround but what we have taken to doing is creating shipping presets that apply only the package type and dimensions, using automation to apply tags, and then applying those presets by filtering for the tag.

Also note that you can update package type without affecting dimensions through a preset that includes package type without dimension, and bulk apply the preset.

Hi Jake,

Thanks for the detail and the suggestions.  This is such a basic bug for a shipping software company. Hopefully they'll fix it.  For other types of packages, I can disable the carrier packages and just use my own package names/dimensions, but for UPS Express Pak, I have to use that package type or it doesn't print UPS Express Pak on the the UPS label and I get a re-rating fee from UPS (I'm shipping with my own UPS account).

I can set all of the package dimensions via the API before creating the shipment, but we use the actual shipstation interface to generate the labels. Where the problem comes in is when someone switches packaging types in Shipstation (as they often do because our default dimensions/weights aren't always accurate once an order is on the scale and ready to be boxed). Because the dimensions aren't updated, we get the wrong rate based on an inaccurate dimensional weight and end up with UPS adjustment fees (unless the person shipping manually enters the carrier box dimensions.

(we're not bulk shipping)

JakeM
Contributor

When are the dimensions not getting updated? Like, which step in the workflow, and how does this part fit into the rest of the workflow? Can you detail the general steps from the order getting into shipstation to getting out the door?There are a few possible solutions, but I'm not sure which would be most helpful without knowing more. 

From the Order page, if you select any UPS Package Type (UPS Pak, UPS Medium, UPS Large, etc) it does not fill in the box dimensions (and of course doesn't change the box dimensions if you switch box types).

This means that unless you manually enter the box dimensions, it is returning the same rate for UPS Pak, UPS Medium, UPS Large -- which all have different dimensional weights that affect the rate.  

If someone either forgets to enter the box dimensions for UPS packaging or changes the box type without updating the dimensions, this results in an incorrect rate & can lead to UPS adjustment fees on top of the added billing.

SO what is the point of even having packaging types listed for carriers? I don't get why this is still a bug.

The workaround is to create custom boxes instead EXCEPT there is a special rate for UPS Pak (at least their is with our account, I'm not sure about UPS by Shipstation).  So switching from one custom box type that fills in the dimensions to UPS PAK, it will still have the previous dimensions resulting in the wrong rate. (UPS never automatically adjusts DOWN, just UP).

Does this make sense?

Again, I just don't understand why the heck Shipstation wouldn't enter the box sizes for carrier provided boxes that are set up in the Settings:Shipping:Packages.