Showing results for 
Search instead for 
Did you mean: 

Dropping devices (printers & weigh scale)


We use Shipstation Connect to talk to our printers and weigh scale. Connect seems to be, somewhat regularly, dropping the connections with these devices. We also find when it happens, Connect needs to be re-installed too. The printers & scale are local to the machine we use Shipstation on and are testing OK. 


Anyone else having this problem? Is there a fix?


We use Google Chrome & Windows 10 Pro.


Hey there @MrCroquet


I want to help get to the root of this behavior you're describing! 


The next time you see this pop up, please follow this troubleshooting step guide from our knowledge base, specifically about printers not showing up! The only other thing that comes to mind to inspect is the type of printer. At this time, although they may work from time to time, it is not recommended or supported to utilize wireless printers, as well as Rollo Printers.


If you do follow all of these steps and continue to need to totally uninstall/reinstall ShipStation Connect every time, I would certainly recommend reaching out to our support team so that we can make that report for investigation. 

From Moderator Davis, May the force be with you!

I have been experiencing the exact same problem. When shipping from the scan tab the scale intermittently stops capturing the weight. Then I switch to the orders tab to ship from there, and of it doesn't automatically capture the weight, but when I click on the scale it captures it just fine which shows that the scale is not loosing connection. The only way to resolve has been to logout then log back in or refresh the page. But it happens again within the next few orders. 


Very frusterating. Please advise.

Hey there @CSN_Shipper


I absolutely understand that frustration, please reach out to our support team right away with that information so we can investigate your direct account instance.

From Moderator Davis, May the force be with you!

How & to who do I report this issue the next time it happens?

My shipper has gone through the trouble shooting guide you suggested above with no change to the situation.This is almost a daily occurrence and is a major waste of our staff's time.

The devices all remain visible in the Windows devices and are operational. It is just Shipstation that looses track of them. The weigh scale is hardwired via USB directly to the tower that Shipstation is used on. All printers are hardwired to the company router. The printers we use are Zebra 450 thermal printer for address labels and a Canon 642 printer for all other docs.

I look forward to your direction as to how & who to report this to so they can either log into our system OR step us through the fix - assuming there is one.



You can reach out to our support team via Live Chat Widget if you'd like, or via email at 


Please follow the steps listed in this article to utilize the Live Chat option


I hope this helps! Happy Shipping 🙂 

From Moderator Davis, May the force be with you!


I have the same problem ever since they have updated to the new SS Connect. Something is not working as it was, I had to reconnect it more often. I already spent multiple hours on phone support and still can't figure out the exact issue.  


One thing I've noted, and I'm not sure if it's relevant.... When the scales have turned off., and a turn back on Shipstation Connect does not detect them. The only way to get detection to happen again is to reload the entire ship station URL. Following this, I see the scales again.

Coalfield - Thanks for the suggestion. However, we never turn off our printers or scales. It's also NOT a power loss situation. We would know if power was lost, even after hours, because the browser would be off. It's not an automatic reload on start-up. 

New Contributor

Same experience here. SS Connect is fragile. At least once a month I get a support ticket from our shipping department stating that they cannot print from ShipStation. This gets bumped up to an urgent/work stopped situation and I have to stop what I am doing, go out to the shipping dept and struggle with getting it to work again.


If I'm lucky a reboot of the workstation running SS Connect will fix it. But more often they not I have to open the Connect UI and struggle with getting it to disconnect and reconnect. Uninstalling the app does not always fix it since there are files left behind that must be manually deleted. 


In defense of ShipStation: I had previously used a different web-based shipping platform and their Windows app (equivalent of SS Connect) was also flaky. Generally speaking, and mostly due to security restrictions, controlling hardware from a web browser is not easy. In the old days this could only be accomplished by using Internet Explorer with ActiveX. But ActiveX had been exploited so many times that it just eventually went away (as did Internet Explorer). In my opinion ShipStation should try to develop an enterprise version of Connect, where Connect runs as a Windows service on a separate computer, and that computer has a constant connection to network printers and/or your printers connected directly to it via USB. Perhaps your company already has a Print Server set up. That would be the perfect place to install this version of Connect if all of your printers were network printers. This way the Service is always running, it's not dependent on the shipping workstation being powered on, or who is (or isn't) logged into it. When you fire up any ShipStation workstation and try to print, it will send the print job to that separate computer running Connect as a Windows Service, from there it gets queued up and then printed to your printers. 


In the meantime it would be helpful if ShipStation would offer a PowerShell script or utility app that would just rip out (uninstall and then delete the leftover files), and re-install ShipStation Connect and AUTOMATICALY re-attach it to your account. Once that's done, the printers show up again.


Another development on our sick Shipstation/Ship Connect apps dropping connections to the scales & printers.


When our shipper left on Friday, everything was working just fine. By default now, he leaves the workstation with Shipstation running and Shipstation open. Monday morning, this week, the printers were all changed from 'Print Directly" through Connect to "Always Prompt". No one had used that workstation from the time he left on Friday to the time he came in Monday.


Tell me how that happens.


I also have this problem. Every week or so I'm digging back through the files to uninstall and reinstall connect. It is beyond frustrating. The scale I can live without it's easy enough to type in the weight but the printer issue is not okay. Today I noticed that although it drops the auto print if I try to reprint it and select the printer, the job does show up in OS print queue but just says incoming and never resolves or does anything else.

Hello @PRPress and everyone else on the thread,

Thank you all so much for being a part of our community.

I am currently looking into this internally to see what I can find out for everyone. If you are currently experiencing similar things I would still recommend reaching out to our support team to report and troubleshoot as your first steps.

-Erin: Your Friendly Neighborhood ShipStation Community Manager


I'm not about everyone else but the problem seems to be resovled, we haven't had any issues with the scales since the day after Christmas.

Occasional Contributor

Shipstation Connect drops connection to our printer- still. Losing hours to repeated uninstall/reinstall tango. Tried the Mac version. Worked on install, but then failed to Connect. Guys this is a serious problem. Please fix it. Love Shipstaion except for this, but it's a dealbreaker and been going on for too long.

Hey there @SSkeptic,


I definitely understand not wanting to uninstall and reinstall ShipStation Connect regularly. 


One change i've heard that has made those "drops" less frequent is to change the "sleep mode" timer on the computer being used. Whenever the ShipStation Connect wielding computer goes into that power saver/sleep mode, the connection will likely be dropped. This may not be a full fix to the issue but it is something i've seen help in the past so I want to share what I can. 


Additionally, if you haven't yet done so, please reach out to our support team so that our team can troubleshoot with you to see if there are any other commonalities to when you're ShipStation Connect is dropping connection. 

From Moderator Davis, May the force be with you!

Occasional Contributor

Thanks, Davis. I see the Shipstation Connect Help and Troubleshooting docs have been updated recently. I would so appreciate a "Shipstation Connect Best Practices" doc - what's our best setup for staying up and running so we can get Ship done?

Howdy @SSkeptic


From searching around, we don't have that sort of "ShipStation Connect Best Practices" type doc, but thats a terrific idea. Perhaps we can get one made! 


I would love to hear from some of our wonderful community here about how your setups are arranged.

From Moderator Davis, May the force be with you!

New Contributor

We run two instances of SS on two computers and this has been a chronic problem forever. Dymo 25lb scales. Can't keep SS Connect logged in or connected. Major waste of time and no joy with SS Support walking through fixes on chat or via email. Don't offer connected scales and printers if you can't deliver; its dishonest.