Showing results for 
Search instead for 
Did you mean: 

UPS from Shipstation setup issues

New Contributor


After setting up the Carriers from Shipstation, the UPS option wasn't on the list. So I clicked on "Update ShipStation Carrier Services to enable new carriers and service options", which takes me to the setup pop-up to add UPS. BUT even though it says "carrier added successfully" it still doesn't show on my list of added shipstation carriers.

Then, when I try buying an UPS label, I get this message: "Failed - Please complete your UPS from ShipStation account setup in order to create shipping labels."

I have tried to setup the UPS from Shipstation dozens of times and it still won't appear as if it's done. I don't know if this is a bug or whatever, but I need my setup to work so I can use the UPS prices.

Also, when I add UPS as a carrier (separate from shipstation ones) I'm able to purchase the labels. BUT I need the labels offered by "UPS from Shipstation" because they have cheaper options than when I integrate UPS separately.

Please help me figure out why the setup doesn't stick.



Hello @drinktche,

Welcome to the community, we are so happy to have you here with us.

I was able to look at your account and I can see that the ShipStation UPS account looks like it was connected. Are you still having trouble getting it to work for you?

Please let us know,

-Erin: Your Friendly Neighborhood ShipStation Community Manager

It still acts as if it's not set up. Every time I select a parcel from UPS it pop-ups the "UPS from shipstation finish setup" on an endless loop. it never setups, it just loops "finish setup".

My personal UPS account gets connected, but the prices are different from "UPS from shipstation"

Hey there @drinktche


If you are still seeing "finish setup" we definitely want to help with that! 


Please reach out to our support team at your convenience and we will be happy to assist 🙂 

From Moderator Davis, May the force be with you!

I'm having the exact same issue. One of the main reasons I chose shipstation was to use UPS to ship orders.  Since your app wont give me UPS as an option despite going through setup multiple times I went back to shipping my recent orders with Pirateship.

New Contributor

Hello? Does anyone actually monitor these boards or are we shouting off into dead space?

Hey there @logboy


We closely monitor all activity in the community space 🙂 

From Moderator Davis, May the force be with you!

Can you tell me when the UPS setup problem will be fixed then? Its still not possible to setup UPS as a carrier. Its just this endless loop of clicking "Finish Setup" that accomplishes nothing. This was reported a week ago in the middle of the Christmas rush and its still not fixed.



I don't have any direct updates myself, so with that in mind, I would advise reaching out to our support department! 


My recommendation is to reach out directly to our support team via email ( or via chat widget. We look forward to hearing from you to get to the bottom of this behavior.

From Moderator Davis, May the force be with you!

New Contributor

I have the same exact issue, and I signed up for the same exact reason, cheaper rates.  Customer support via email was my first route. I had some very enthusiastic agents wanting to help. After several back and forth emails they stopped replying. Last reply was.. "You will be contacted once they are able to fix this and add the UPS by ShipStation account."

I sent two follow up emails after that , no response.  I am shopping around for other competitors while (if) this gets resolved. I prefer shipstation because I use it at my other job under a different account and it works great.

Hey there @nyshipper


I'm glad to hear that you reached out via email! That is absolutely the right thing to do. If it has been a couple days and you haven't heard back yet, I am very confident you will hear back soon! 

From Moderator Davis, May the force be with you!

they did reply stating...

At this time we have no additional updates from our development team on this issue. We are awaiting on our development team to review this further and have no ETA on when a resolution will occur, however I can see that this case has been prioritized and is actively being worked on. We will be sure to update you with any necessary information as we continue to troubleshoot further.

New Contributor

I have the exact same problem activating UPS.  It’s a ridiculous loop where you agree to terms on the pop up screen, and then it goes back to not be activated.  Try over again and again.  I’ve been a customer for over ten years so I know I have everything set up correctly.  It’s a software issue on shipstation’s end, but I too get the runaround that they will look into it.  They never get back to me.  Customer service has gotten so bad.  It’s terrible.  Come on shipstation - HELP ME and the others with this issue!