cancel
Showing results for 
Search instead for 
Did you mean: 

Why are my email templates only showing up in HTML?

SuperMgr-Sarah
Community Manager
Community Manager

Original post from user Kara Froula

 

How can I view and edit my email templates? They are only showing in HTML right now. I have tried to click the edit HTML button and it does nothing. I want to be able to add text and need to be able to preview it as the normal email.

 

email html error.png

 

Sarah H.
Austin, Tx
1 ACCEPTED SOLUTION

SuperMgr-Sarah
Community Manager
Community Manager

I wanted to update everyone that this issue has been resolved and the WYSIWYG email template editor should now be functioning normally, even when the[TrackingURL] and [StoreWebsiteURL] field replacements are present (as they are on the default template). 

 

If you are still experiencing any issues with accessing the WYSIWYG editor for email templates, please open a ticket ShipStation support.

Sarah H.
Austin, Tx

View solution in original post

4 REPLIES 4

SuperMgr-Sarah
Community Manager
Community Manager

Hello Kara, 

 

Thank you for your post and for being a member of our community.

Based on the screenshot you sent, I can tell that there are two things at play here.
The first part is the highlighted message- as shown in the screenshot below- that appears when the code you have entered cannot be previewed in the text editor so you will be editing in HTML.

 

email-temp1.png

 

The second part is the red text below the first message. When you see this red text it means that you have added an unsupported element in the HTML editor. The text will let you know which element or elements need attention. You will not be able to exit the HTML editor until the unsupported element is deleted (in this case the <html> tag... this already exists in the template outside of the visible part of the editor).

 

email-temp2.png

 

Please let us know if this helped you out or if you need further assistance. 

Sarah H.
Austin, Tx

Marek3D
First-timer

Could you explain why the same thing happens with the default template?  

SuperMgr-Sarah
Community Manager
Community Manager

Hello!

 

Yes. I was recently made aware of an issue with our default email template that has been escalated to our developers. Currently, the href attributes that use the [TrackingURL] and [StoreWebsiteURL] field replacements are failing validation in our template editor.

 

This issue is in the queue to be fixed, but for now if you want to get back to the visual editor, the workaround is to remove the href attributes for those two field replacements. If you don't want to remove those elements from your email template and don't mind working in the HTML editor, though, the actual emails that are sent with those href attributes should work fine. It's just the validator that is the issue, not the actual HTML. 

 

I hope that helps!

Sarah H.
Austin, Tx

SuperMgr-Sarah
Community Manager
Community Manager

I wanted to update everyone that this issue has been resolved and the WYSIWYG email template editor should now be functioning normally, even when the[TrackingURL] and [StoreWebsiteURL] field replacements are present (as they are on the default template). 

 

If you are still experiencing any issues with accessing the WYSIWYG editor for email templates, please open a ticket ShipStation support.

Sarah H.
Austin, Tx

View solution in original post