Showing results for 
Search instead for 
Did you mean: 

Scale Not Reading Correctly- Ongoing- Frustrating

New Contributor

So we're a long time SS user. We've had the same scales for several years- older Mettlers that do a great job. 

A little over a month ago, the scales just stopped passing a weight back to SS. We contacted support, who had us take a video, as this is intermittent and happens only randomly. Most of the time we cannot use scale weights at all, and have to either guess, or hit refresh on the "scan" window.

With hundreds to ship, you can imagine how fun that is. 

"Senior" support was supposed to look at it. That was nearly a month ago. Despite repeated attempts, they never answered back. Tried again last week. Same- nothing.

We're uninstalled and reinstalled Connect, unplugged scales, removed scales entirely, restarted a million times, nothing. MORE than one terminal. No clue how to fix it, and no guidance.

Anyone else have this issue? Super frustrating, and the first time SS has had us seriously angry.


New Contributor

Not a solution, but have you tried different scales?  We use MT PS60's and have had the USB ports on them go bad at times to where they will supply power to the scale, but not read properly.  We have a few older PS60's that we have that are labeled as bad usb ports that we use for other purposes in our warehouse not connected to a computer.  Just a thought.  Also try another computer with the same scale (to rule out computer), different scale on same computer (to rule out scale) and if not working on either then potentially a SSC issue.

Hey there @shipstation35


This is a terrific troubleshooting plan you've provided here. Hopefully this helps out @admin69


Thank you for your participation and eagerness to help out your fellow community members! 🙂 

From Moderator Davis, May the force be with you!

Unfortunately, it is on both scales and started at the exact same time. There appears to be no rhyme or reason to it. 

Howdy yall, 


If you are continuing to experience this behavior and haven't done so yet, please reach out to our support department to make this report. Not only will it assist with the investigation, but it will also ensure you are notified immediately upon resolution 🙂 

From Moderator Davis, May the force be with you!

Occasional Contributor

We also are experiencing this issue at at least 2 of our workstations. Just started today, tried all of the steps mentioned.



I've been having the EXACT same problem on both of our scales. Both started having the same issue on the same day roughly a month ago. Have to refresh the page after every random number of scan, sometimes I can scan 50 without any issues, then other times I'm having to refresh every 3-4 scans. Very frustrating indeed!!!

Just a few moments ago though I started getting a error message related to the issue. So hopefully they're working on a fix or maybe this screenshot can help the techs out...



Occasional Contributor

We also provided support with a video of the issue a few days ago.

New Contributor

I had a similar problem two years ago. In that case, I had a print client (like Shipstation connect) for a separate program that was intercepting the signal from the scale, so when I tried to read the scale in Shipstation it would provide no numeric value. In that case I was able to disable that program from reading all scales to solve the issue.

We started experiencing this issue again this week on just one of our three shipping stations. The previous solutions no longer seem to help.

New Contributor

I am having the same problem. It randomly doesn't show the weight or doesn't even show my scale as a choice, unless I go back and refresh the ShipStation Connector. Then I have to go back to the settings and set them to the scale again before I can get a weight.