Showing results for 
Search instead for 
Did you mean: 

Amazon Orders & Phone Number Import Issue

New Contributor

Amazon uses phone numbers to keep customer data anonymous. This is a 10 digit phone number and a 5 digit extension. On Friday someone at ShipStation decided to import this as a 15 digit or 16 digit if the 1 is included number. Too long for UPS and FedEx labels. Now it throws an error for each label. User needs to delete phone number on each label to proceed.  


When will this be rectified?



New Contributor

I have over 300 orders failing. How did this happen. Amazon is probably the largest user base for Shipstation and why is this happeing?


New Contributor

Same issue here. We have to manually edit each order for the time being, greatly increasing the time it takes to ship a package.


We use FedEx nowadays, but we used to use UPS. Amazon started this phone # business about a year and a half ago. Are you a new user, new to UPS, or did something change recently that I just haven't come across yet?

Just a guy with an awesome beard who loves coffee, Bourbon, and music. I also sell a ton of truck and Jeep accessories.

Community Manager
Community Manager

Hello Everyone, 


Thank you for your contributions to this thread and our Community. Apologies for the delay in getting this information out, but a fix to this issue was pushed out around 11 am CST on Monday.


Please feel free to either reply to this thread and reach out to support if you are still seeing errors around this at this point in time. 


-Erin: Your Friendly ShipStation Community Manager 

Would it be too much to ask that Shipstation indicate "somewhere", what "version", or "push" we are running under?


I've never known any company as large as SS to not give any indication of updates to their software, nor versioning (of any detail) that we are running.

I thought this problem had been fixed as I stated earlier but realized today that it is actually only happening now with Canada Post labels, UPS is fine. So, still having the issue, how do we fix it??


Edit: Didn't mean to reply to Dirk meant to reply to Erin-MANAGER


we are having this issue. How do we fix it?

This fixed itself. Stopped throwing up errors, prints as one long number now.

Hi @ec007 , 


Thank you for reaching out and for being a part of our community. 


I am thinking that we need to get you to our support team to get this figured out. Do you currently have a ticket open with support about this? 


If so can you send me this ticket number via private message. If not please reply here and I will reach out via private message to gather more information. 


-Erin: Your Friendly ShipStation Community Manager 


This issue is still going on. How come it is not solved since 2021? 


Just wanted to add that this problem is not fixed. I realized that is is specifically an problem when shipping through Canada Post. does not have the extension numbers in their phone numbers. I thought the issue had been fixed to make the phone numbers all one long line, turned out it wasn't.


So to reiterate... with extension numbers trying to send through Canada Post give an error when trying to print a label for the extension number and when the extension number is deleted they print fine.


This issue is still going on. How come it is not solved since 2021?


We are experiencing this same issue, is there a way you can work with other API or code it in a way that will automatically change the phone number to an acceptable format? Currently any phone number including brackets throws an error message and has to be manually edited by someone in our warehouse. With GLS Canada only.

Talked to the UPS FedEx managers and Shipstation. We couldn't find a way.

New Contributor

This is still an issue. Why has it not been resolved? And now with the "New View" you can not edit the customer information to manually remove the +1. This is complete insanity.